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Electronic Service Tool - TG210, TG230, TG255, TG285

Section 1:  General Information

The Electronic Service Tool is a laptop computer based service and diagnostic tool that communicates
with the vehicle (tractor, combine, implement, etc.) data bus. The Electronic Service Tool will:

• Display the controller software version information.
• Retrieve fault codes stored within controllers.
• Monitor switch and sensor parameter information.
• Download software to controllers.
• Provide a Windows based link to the Engine Diagnostic Tool, Engine Diagnostic Tool Help, and
Engine Calibration Download Tool.

• Configure vehicle features relating to the specific model.
• Provide troubleshooting and diagnostic information.
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Section 2:  Connecting the Electronic Service Tool

The Electronic Service Tool consists of the following:

Item Number Description
Identification Guide - Locations and appearance of some components may vary.

1 CAS40048 Pouch - Used to store various adapters.

2 Laptop Computer AC Power Cord

3 Electronic Service Tool Laptop Computer

1

3
2

EST522-11
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Electronic Service Tool Computer Port Identification

Remove the Electronic Service Tool laptop computer from the carrying case. The back of the computer is
equipped with ports to connect the computer to the vehicle..

Item Number Description
Identification Guide - Locations and appearance of some components may vary.

1 Modem

2 USB Port (Universal Serial Bus) - Used for a variety of peripheral devices (scanners, 
printers, etc.)

3 PS2 Port - Used for external mouse or keyboard (not supplied).

4 AC Power Socket

5 Video Port - Used for external monitor

6 Serial Port - Used as a connection point for the Electronic Service Tool interface 
harness cable (CAS2580 gray RS232 cable).

7 Parallel Port

457 6

321

EST522-10
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Electronic Service Tool Cable Connections

When the external (communication and power) harnesses are connected, the Electronic Service Tool
will look as shown.

Item Number Description
Identification Guide - Locations and appearance of some components may vary.

1 Electronic Service Tool Laptop Computer

2 AC Power Cord

3
CAS2580 Electronic Service Tool Interface Harness Cable (RS232 Gray Cable) - 
Used to connect vehicle communication adapters to Electronic Service Tool serial 
port.

1

3

2

EST522-9
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When the external (vehicle and user) harnesses are connected, the Electronic Service Tool will look as
shown.

Item Number Description
Identification Guide - Locations and appearance of some components may vary.

1 AC Power Cord

2 External Mouse (not supplied)

3
Protocol Adapter (Dearborn CAS2578)
Electronic Service Tool Interface Harnesses (CAS2579)
Gray Computer Cable (CAS2580)

1

2

3

RR00J035
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Install the interface harness and protocol adapter (Dearborn interface box) to the vehicle diagnostic
connector. Connect the DC to AC power convertor to the vehicle cigar lighter as shown. 

Item Number Description
Identification Guide - Locations and appearance of some components may vary.

1 DC to AC Power Convertor

2 Cigar Lighter Socket

3

CAN Programming/Diagnostic Connector - Connect to the Electronic Service Tool 
using: 

• CAS2580 RS232 adapter cable
• CAS2578 protocol adapter
• CAS2579 adapter cable

1

3

2

RR00J048
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Place the Electronic Service Tool in a safe location near the power supply. Protect the cords to prevent
damage to the Electronic Service Tool during use.

Item Number Description
Identification Guide - Locations and appearance of some components may vary.

1 Battery and Floppy Drive Indicators

2 DC to AC Power Convertor

3 Protocol Adapter

4

CAN Programming/Diagnostic Connector - Connect to the Electronic Service Tool 
using: 

• CAS2580 RS232 adapter cable
• CAS2578 protocol adapter
• CAS2579 adapter cable

5 Right Mouse Button and Left Mouse Button

6 Electronic Service Tool Laptop Computer

5

6

1

4

2

RY02T002

3



9

Section 3:  Selecting the Vehicle Application

If the Electronic Service Tool is not opened to the appropriate vehicle application (and the appropriate
Serial Number), it can be selected using the Tool pull down menu and the appropriate vehicle model
(tractor, combine, or other) selection.

Left Click Mouse On:Tool > Appropriate Vehicle Model

Anytime the Electronic Service Tool is started, the CONTROLLER STATUS screen will be displayed. Any
of the available Electronic Service Tool applications can be selected from the Tool pull down menu.

To select an application, use the left button of the mouse to click on the Tool pull down menu and select
the desired application.

RZ02T001
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An Electronic Service Tool screen displays. Using the left button of the mouse, click the OK 
button.

Left Click Mouse On:OK

The Electronic Service Tool will reconfigure to the application selected. The vehicle application
CONTROLLER STATUS screen displays.

Note: After the Electronic Service Tool has been reconfigured, it can be used in the application 
selected.

RZ01G001

RZ02T002
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Section 4:  Controller Status Screen

As the Electronic Service Tool is started or reconfigured to the vehicle (tractor, combine, other)
application, the CONTROLLER STATUS screen will display. The following controllers could be accessed
from the CONTROLLER STATUS screen:

• ARM RH Armrest Controller
• AUX Remote Hydraulic Controller
• ENG Engine Controller
• HITCH Hitch Controller
• INST Tractor Monitor
• PERF Performance Monitor
• PTO PTO/MFD/Diff Lock Controller
• TRANS Transmission Controller

RZ02T004
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Item Number Description
1 Application Title (Electronic Service Tool - Vehicle Model)

2 Tool Bar (Screen Function) Icons

3 Screen Function Identification

4 Minimize, Restore, Maximize, and Close Buttons

5 Controller Identification Window

6 Function Buttons (Dark = Active; Gray = Inactive)

7 Status Bar Comm Link Status (Communication Status)

8 Pull Down Menus

6

7

8

5

2
4

1

3

RZ02T111
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Application Title

The application title is located in the upper left corner of the screen. It identifies what vehicle can be
communicated with from this screen.

Important: Be aware of:

• The vehicle PIN number 
• The engine serial number
• The engine control module part number

Tool Bar (Screen Function) Identification Icon

These icons are located in the Tool Bar area of the screen. Each vehicle application has individual
functions that can be performed. To move to another function of the Electronic Service Tool, place the
cursor arrow over the desired Tool Bar screen function icon. Using the left button of the mouse, click on
the icon to transfer to the desired function. Specific purpose for each icon will be discussed with the
individual vehicle information in this manual.

Icon Symbol Icon Name (Function)

Open File - The Open File command provides a shortcut to open an existing file for 
the Electronic Service Tool testing and analysis. This command can be used only in 
Electronic Service Tool screens that provide retrieval of information. In all other 
screens it is disabled.

Save File - The Save File command provides a shortcut to save the active window 
information (including any changes) to a new or an existing file. This command can 
be used only in Electronic Service Tool screens that provide saving of information to 
a file. In all other screens it is disabled.

Controller Status - The Controller Status screen allows the user to identify the 
Software ID, Software Version, the Communication Status, and retrieve version 
information from all controllers.

Retrieve Controller Faults - The Retrieve Controller Faults screen allows the user to 
read individual controller fault information. Faults can be retrieved from a single 
controller or all controllers.

Monitor - The Monitor screen allows the user to view inputs (parameters) to each of 
the controllers.

Programming - The Programming screen allows the user to view the controller 
software information installed in each of the controllers. It also allows the user to 
download updated software to each of the controllers. 

RZ01L003

RZ01C006
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Screen Function Identification

This screen area is located in the upper center part of the screen. It identifies the current screen function
(CONTROLLER STATUS shown).

Additional Tools - In this application, the Additional Tool screen provides a link to:
• Start the Engine Diagnostic Tool 
• Start the Engine Diagnostic Tool Help
• Start the Engine Calibration Download Tool

Configure - The Configure screen allows the user to configure:
• Fuel Tank Size Selection
• Vehicle Model Selection

Troubleshoot Problem - The Troubleshoot Problem screen allows the user to:
• View diagnostic fault code information for all controller faults
• View vehicle component information
• View vehicle schematic information
• View vehicle component locations

Help On Item - The Help On Item screens provide information concerning how to 
operate the Electronic Service Tool screen functions.

User Help - The User Help screen provides help information on the Electronic 
Service Tool application.

Item Number Description
1 Screen Function Identification (CONTROLLER STATUS shown)

Icon Symbol Icon Name (Function)

RZ02T003

1
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Minimize, Restore, Maximize, and Close Buttons

 This area is located in the upper right corner of the screen. The buttons allow the user to:

•  Minimize the Electronic Service Tool screen. This button is used to reduce the window size. The
window is open but it is represented by a button in the task bar.

•  Restore the Electronic Service Tool screen. This button is used to return a window to its previous
size.

•  Maximize the Electronic Service Tool screen. This button is used to increase the window to its
largest possible size.

•  Close the Electronic Service Tool application. This button is used to close the application.

Controller Identification Window

This screen area is located in the center of the screen. It identifies the controllers that can be
communicated with from this application, software identification, and individual controller communication
status. 

RZ02T004
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Function Buttons (Dark = Active; Gray = Inactive)

The function buttons can be located in various areas of the screen. They allow specific information to be
gathered from the vehicle controllers. If the function button is dark, it is currently active and can be used
to gather information from the controller(s). If the button is gray, it is not currently active and can not be
used to gather information from the controller(s). Additional information will be discussed with the
individual vehicle information in this manual.

Comm Link Status (Communication Status)

This area is located in the lower right corner of the screen. It allows the user to identify the
communication status with the vehicle. 

Note: If Comm Link Down is displayed in the Comm Link Status area of the screen, ALL controllers will 
be OFF LINE.

Item Number Description

1
Retrieve Version Information For the Selected Controller (Inactive Button) - 
Function buttons which appear in gray text will not operate as the left button 
of the mouse is used to click the function.

2
Retrieve Version Information For All Controllers (Active Button) - Function but-
tons which appear in dark text will operate as the left button of the mouse is 
used to click the function.

1

2

RZ00JO43

RZ00JO45RZ02C563
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Pull Down Menus 

The pull down menus allow the user to:

1. Exit the Electronic Service Tool Application.

Left Click Mouse On:File

2. Change Electronic Service Tool Application.

Left Click Mouse On:Tool

3. Adjust Electronic Service Tool functions.

Left Click Mouse On:View

4. Reset Electronic Service Tool communication link.

Left Click Mouse On:Communication

5. Change Electronic Service Tool screen function.

Left Click Mouse On:Window

6. Research Electronic Service Tool help information and version number.

Left Click Mouse On:Help

To operate a pull down menu, use the left button of the mouse to click on the pull down menu name, then
the selection below.

Left Click Mouse On:File > Exit

Note: If part of the pull down menu is dark, it is currently active and can be selected from the menu. If 
part of the pull down menu is gray, it is currently inactive and can not be selected from the menu.

RZ02T005

RZ02T006
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Section 5:  Using Pull Down Menus

At the top of the screen below the application title are the following pull down menus:

File

The File pull down menu allows:

• Files to be opened.
Left Click Mouse On:File > Open

• Files to be saved.
Left Click Mouse On:File > Save

• Files to be printed.
Left Click Mouse On:File > Print

• The user to exit the Electronic Service Tool.
Left Click Mouse On:File > Exit

RZ02T007
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Tool

The Tool pull down menu allows:

• Changing Electronic Service Tool applications.
Left Click Mouse On:Tool > appropriate vehicle selection

RZ02T001
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View

The View pull down menu allows:

• Activating the Tool Bar. When activated, the Tool Bar is illustrated with a check  mark symbol). 
Left Click Mouse On:View > Toolbar

• Activating the Status Bar. When activated, the Tool Bar is illustrated with a check  mark symbol). 
Left Click Mouse On:View > Status Bar

• Deactivating the Tool Bar. 
Left Click Mouse On:View > Toolbar

• Deactivating the Status Bar.
Left Click Mouse On:View > Status Bar

• Adjusting the rate the screen values are updated. 
Left Click Mouse On:View > Parameter Update Rate > 2 seconds

• The Electronic Service Tool Screens to be displayed in English or Metric units. 
Left Click Mouse On:View > Type of Measurements > English

RZ02T008
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Communication

The Communication pull down menu allows:

• The Electronic Service Tool communication link to be reset.
Left Click Mouse On:Communications > Reset

Window

The Window pull down menu allows:

• Changing screen function windows in a manner similar to selecting an icon from the Tool Bar. The
current screen selection is illustrated with a check  mark symbol.

Left Click Mouse On:Window > Controller Status

RZ02T009

RZ02T010
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Help

The Help pull down menu allows:

• Search help subjects of the Electronic Service Tool. 
Left Click Mouse On:Help > User Help

• Electronic Service Tool software version verification. 
Left Click Mouse On:Help > About Electronic Service Tool

RZ02T011
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Section 6:  Controller Status

From the CONTROLLER STATUS window, controller version information can be obtained. Controller
version information is used to determine if the hardware and software installed are compatible with the
customer needs and are updated properly. 

Controller version information contains:
• Controller Name
• Boot Code Information
• Manufacturing ECU ID
• Hardware ID
• Software ID
• Software Version

To view the controller version information: 

Item Number Description

1

Retrieve Version Information For The Selected Controller button - To view 
controller information from an individual controller, use the left button of the 
mouse to select the controller in the controller list to view version information 
from. As the controller is selected the name of the controller will be 
highlighted (darkened). To view the controller version information, use the left 
button of the mouse to click on the RETRIEVE VERSION INFORMATION 
FOR THE SELECTED CONTROLLER button in the lower center portion of 
the screen.

2 Retrieve Version Information From All Controllers button - Selecting this but-
ton will display the controller version information from all controllers.

1

2

RZ00M137
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Controller Version Information — One Controller

Controller Version information contains:

• Controller Name
• Boot Code Information
• Manufacturing ECU ID
• Hardware ID
• Software ID
• Software Version

To view controller version information from an individual controller, use the left button of the mouse to
select the desired controller. As the controller is selected the name of the controller will be highlighted
(darkened). 

To view the controller version information, use the left button of the mouse to click on the RETRIEVE
VERSION INFORMATION FOR THE SELECTED CONTROLLER button in the lower center portion of
the screen. 

RZ02T012
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A CONTROLLER VERSIONS screen will be displayed. 

Note: The refresh  button is used to update the information on the screen. Use the left button 
of the mouse to click on the refresh button and the display of the screen will be updated.

RZ02T013
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The Exit button can be used to return to the CONTROLLER STATUS window. Using the left button of the
mouse, click on the Exit  button to close the CONTROLLER VERSIONS screen.

Controller Version Information — All Controllers

To view the controller version information from all controllers, use the left button of the mouse to click on
the RETRIEVE VERSION INFORMATION FROM ALL CONTROLLERS button in the lower center
portion of the screen. 

RZ02T015
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A CONTROLLER VERSIONS screen will be displayed. To allow viewing of information not currently
shown on the Electronic Service Tool screen a scroll bar is located along the right hand side of the
screen. To view information lower on the screen move the cursor arrow over the down arrow  of the
scroll bar and hold the left button of the mouse until the desired portion of the screen is displayed.

RZ026017

Product: New Holland TG210/TG230/TG255/TG285 Electronic Service Tool User's Manual
Full Download: https://www.arepairmanual.com/downloads/new-holland-tg210-tg
230-tg255-tg285-electronic-service-tool-users-manual/

Sample of manual. Download All 130 pages at:
https://www.arepairmanual.com/downloads/new-holland-tg210-tg230-tg255-tg285-electronic-service-tool-users-manual/

https://www.arepairmanual.com/downloads/new-holland-tg210-tg230-tg255-tg285-electronic-service-tool-users-manual/
https://www.arepairmanual.com/downloads/new-holland-tg210-tg230-tg255-tg285-electronic-service-tool-users-manual/

